PCTRIO - il portale del software gratuito
Visualizzazione dei risultati da 1 a 7 su 7
  1. #1
    Danko5 non  è collegato Junior Member
    Registrato dal
    Mar 2010
    Messaggi
    4

    Installazione Vbulletin" Installer not compatible with PHP 4"

    Salve a tutti
    Chiedo gentilmente il vostro aiuto!


    Sto provando a installare Vbulletin 4.0.2 sul mio sito.
    Sono su hosting aruba spazio web + mysql
    Il server non è dedicato.
    Ho configurato il config.php
    uppato tutti i file via cute-ftp sul server
    e una volta che lancio install.php mi vien fuori questo:
    "Installer not compatible with PHP 4"

    Ho verificato sul control panel di aruba:
    La versione php del mio spazio è: php 5.2.13 e addirittura posso portarla a 5.3.2 anche se sconsigliato da aruba per compatibilità...

    Quindi? Come mai l'installazione non riconosce la versione php reale?


    Il file config.php l ho settato così:

    // ****** DATABASE TYPE ******
    // This is the type of the database server on which your vBulletin database will be located.
    // Valid options are mysql and mysqli, for slave support add _slave. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
    // for slave options just append _slave to your preferred database type.
    $config['Database']['dbtype'] = 'mysql';

    // ****** DATABASE NAME ******
    // This is the name of the database where your vBulletin will be located.
    // This must be created by your webhost.
    $config['Database']['dbname'] = 'NOMEDEL DATABASE';

    // ****** TABLE PREFIX ******
    // Prefix that your vBulletin tables have in the database.
    $config['Database']['tableprefix'] = '';

    // ****** TECHNICAL EMAIL ADDRESS ******
    // If any database errors occur, they will be emailed to the address specified here.
    // Leave this blank to not send any emails when there is a database error.
    $config['Database']['technicalemail'] = 'lamia@email.it';

    // ****** FORCE EMPTY SQL MODE ******
    // New versions of MySQL (4.1+) have introduced some behaviors that are
    // incompatible with vBulletin. Setting this value to "true" disables those
    // behaviors. You only need to modify this value if vBulletin recommends it.
    $config['Database']['force_sql_mode'] = false;



    // ****** MASTER DATABASE SERVER NAME AND PORT ******
    // This is the hostname or IP address and port of the database server.
    // If you are unsure of what to put here, leave the default values.
    $config['MasterServer']['servername'] = 'IPHOST';
    $config['MasterServer']['port'] = 3306;

    // ****** MASTER DATABASE USERNAME & PASSWORD ******
    // This is the username and password you use to access MySQL.
    // These must be obtained through your webhost.
    $config['MasterServer']['username'] = 'username';
    $config['MasterServer']['password'] = 'lamiapassword';

    // ****** MASTER DATABASE PERSISTENT CONNECTIONS ******
    // This option allows you to turn persistent connections to MySQL on or off.
    // The difference in performance is negligible for all but the largest boards.
    // If you are unsure what this should be, leave it off. (0 = off; 1 = on)
    $config['MasterServer']['usepconnect'] = 0;


    Il resto resta intatto

    Ho sbagliato qualcosa?

    Ringrazio in anticipo chi mi vorrà dare una mano a capire...

  2. # ADS
    PUBBLICITA Link Sponsorizzati
    Registrato dal
    Sempre
    Messaggi
    Molti
     
  3. #2
    Danko5 non  è collegato Junior Member
    Registrato dal
    Mar 2010
    Messaggi
    4
    Credo di aver capito...ho installato la suite in un altro sito sempre di aruba e funziona perfettamente...credo che dipenda dal fatto che in quel sito ho un altro forum in sottocartella vbulletin...e non vanno daccordo sullo stesso sito. Volevo evitare di fare l aggiornamento...ma mi vedo costretto a sto punto.

  4. #3
    L'avatar di Wolly
    Wolly non  è collegato Amministratore
    Registrato dal
    May 2004
    Messaggi
    53,888
    Inserimenti blog
    2

  5. # ADS
    PUBBLICITA Link Sponsorizzati
    Registrato dal
    Sempre
    Messaggi
    Molti
     
  6. #4
    L'avatar di ceccus
    ceccus non  è collegato Amministratore
    Registrato dal
    May 2004
    residenza
    Siena
    Messaggi
    30,816
    SAlve,
    [Occorre essere registrati per visualizzare il link. ]

    Volevo evitare di fare l aggiornamento...ma mi vedo costretto a sto punto.
    A che cosa ti stai riferendo ? al fatto che hai già un VB installato vecchio che gira su PHP 4.x.y ???

    Ciao !!
    -- Ceccus Staff PCTrio.com --

    Facebook PcTrio CLICCA "MI PIACE"

  7. #5
    Danko5 non  è collegato Junior Member
    Registrato dal
    Mar 2010
    Messaggi
    4
    Niente da fare :-(

    Avevo un forum vbulletin 3.7.2 che girava sul sito (ha circa 2 anni...ma ora non saprei se prima girava su php 4 ora comunque facendo un controllo risulta su php 5.2.13)

    Le ho provate tutte, ho fatto un backup e sovrascritto il vecchio forum con la nuova suite 4.0.2 ma quando lancio l upgrade...
    "Upgrade not compatible with PHP 4"

    e ora?

    Scarseggio di iniziative....
    Possibile che aruba dichiari dal cpanel del sito che gira su php 5.2.13 e invece il mio sito sia ancora su php4? Mi sembra impossibile.

    Unico dubbio rimasto: La cartella cgi-bin presente nella root principale dei siti linux su aruba (che non so proprio a cosa serva) avendola erroneamente cancellata tempo fa... e ricreata comporta qualche problema?

    Qualche idea?

    Grazie Ceccus!

  8. #6
    Danko5 non  è collegato Junior Member
    Registrato dal
    Mar 2010
    Messaggi
    4
    Come dicevo qualche ora fa...
    Possibile che aruba dichiari dal cpanel del sito che gira su php 5.2.13 e invece il mio sito sia ancora su php4? Mi sembra impossibile.
    E invece non so perchè non so per come...stasera rientro nuovamente nel pannello di controllo del php info del mio sito e magicamente è apparsa la versione obsoleta php 4.4.9 selezionata !!! Ma prima non c' era giuro!!! Non sono pazzo!!! Tant'è che l ho scritto nel primo post in alto...
    Va bene lasciamo cadere la cosa...misteri di Aruba.....ho selezionato quella più recente e ora vediamo se riesco a upgradare senza problemi ...

    Grazie comunque per il vostro interessamento...,magari dovrò disturbarvi ancora.

    Un saluto a tutti!

  9. #7
    L'avatar di ceccus
    ceccus non  è collegato Amministratore
    Registrato dal
    May 2004
    residenza
    Siena
    Messaggi
    30,816
    Salve,
    Allora, l' errore è chiaro ... puoi vedere la versione del PHP, anche dal tuo pannello di controllo VBulletin ... anzi, quello è effettivamente quello che gira ... dal pannello di controllo del tuo spazio, vedi l' ultima versione di PHP disponibile, ma non è detto che sia quella installata ... e VB4 utilizza delle features di PHP che solo la versione 5 ha disponibili ... quindi, questo è il discorso relativo al versioning di PHP ...
    Facci sapere ...

    Ciao !!
    -- Ceccus Staff PCTrio.com --

    Facebook PcTrio CLICCA "MI PIACE"


Discussioni simili

  1. File di installazione "driver whiz" non cancellabile
    Da VIMARA nel forum Win 2000/XP/2003
    Risposte: 0
    Ultimo messaggio: 3rd March 2010, 15:05
  2. Risposte: 0
    Ultimo messaggio: 7th December 2009, 01:12
  3. Risposte: 4
    Ultimo messaggio: 30th November 2009, 13:31
  4. "Scorciatoie" per vBulletin con Firefox
    Da dNow nel forum Applicazioni Software
    Risposte: 0
    Ultimo messaggio: 14th April 2007, 12:30
  5. Installer \"corrotto\"
    Da aldo.85 nel forum Miscellanea Hardware
    Risposte: 2
    Ultimo messaggio: 10th August 2004, 15:58

Visitatori hanno trovato questa pagina cercando

Nobody landed on this page from a search engine, yet!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Home  |   Software  |   Drivers  |   Guide  |   Sicurezza  |   Area gestione
Created by - best view 1024x768 and over. - C.F. 92048990524
PCTrio McAfee PCTrio AVG PCTrio Norton PCTrio Google